Administrator Guide 3.3 | Open Assessment Technologies S.A.

Administrator Guide 3.3

Prerequisites

TAO can be installed on any Operating System that supports the prerequisite versions of PHP, Apache(or other webserver), and either MySQL, MariaDB, or Postgres for the database. This guide only covers installation with Apache and MySQL.

Server-Side

The following versions are required in order to install TAO.

  • Apache 2.4 - or equivalent web server
  • PHP 7.2
  • MySQL 5.7, MariaDB 10.1, or PostgreSQL 9.5

It is recommended to install on a Linux based distribution such as Ubuntu, Debian, CentOS, RHEL or similar.

Client-Side

As TAO runs in a browser on the client-side, the following are recommendations for user systems:

  • Internet Explorer 11
  • Chrome – recent version
  • Firefox – recent version
  • Safari – recent version
  • Edge – recent version

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×